Prophet & Loss

Just had an interesting repair.

Customer had a Prophet 600. The unit powered up correctly, ran through the tuning cycle, and appeared to be perfectly fine – for about three minutes. Then the control panel would lock up and pressing buttons had no effect. If you turned it off and back on, the same thing happened. Obviously, unless you’re in a band playing REALLY short songs, this rendered it pretty much unusable.

The symptoms would generally lead me to think it was either a power or thermal issue. I dug up the schematics and checked all the voltages; they were all fine. The main chips – including the processor – are all socketed, so I popped them all out, checked for bent or mis-aligned pins, and reinstalled everything. No difference. It didn’t appear to be thermal – I got the same few minutes of normal operation whether it had been on for a minute or an hour.

In my day job I work with computers so at this point I’m thinking it’s a bad chip. The consistency of the failure, though, is unusual. In talking to a friend about it at some point in the conversation I was explaining that this unit is microprocessor based…which got me thinking (not as dangerous as it sounds). Once the unit finishes tuning, it has to monitor the status of all the front panel controls, not just the switches but also the rotary pots. Suppose one was dirty? It was conceivable that the CPU could read that as constantly changing, and hang up attempting to deal with it.

I removed all the knobs, removed the two control panel PCBs from the case, and cleaned & lubed all of the pots & switches. Plugged it back in, waited three minutes and then…it kept working. The first time I let it on for a couple of hours, randomly changing patches or moving controls every time I walked by. The second time, it was on for five hours – still no lockups. Re-loaded the factory patches, made sure the oscillators were properly scaled, and it was back to operating like it just rolled off the line.

First time I’ve run into this, but it’s conceivable that any programmable knobs-and-switches synth could develop this issue.

Advertisements

Posted on December 11, 2012, in Repairs, Synthesizers and tagged , , , , . Bookmark the permalink. Leave a comment.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: